컨텐츠 바로가기
69613200 0592021072269613200 08 0802001 itscience 7.1.5-RELEASE 59 지디넷코리아 0 false true false false 1626936589000

'윈도·리눅스' 취약점 등장..."최고 권한 탈취 위험"

댓글 첫 댓글을 작성해보세요
주소복사가 완료되었습니다

윈도는 보안 패치 미출시…주 후반 발표 예상

(지디넷코리아=김윤희 기자)운영체제(OS) 윈도와 리눅스에서 최고 권한 탈취까지 가능한 취약점이 새로 발견돼 주의가 요구된다.

윈도 취약점은 한 보안 연구원이 윈도 11 베타 버전을 테스트하면서 발견됐으며, 2018년 10월 이후 출시된 윈도10 1809 이상 버전에도 영향을 끼친다.

이 취약점은 시스템 권한이 제한된 사용자에게 사용자 계정정보를 저장하는 데이터베이스(DB) 파일인 보안계정관리자(SAM) 읽기를 허용한다. 이에 따라 패스워드로 잠긴 데이터에 접근할 수 있고, 결과적으로 시스템 관리자 권한 계정 생성도 가능해진다. 이후 특정 프로그램을 설치하거나 데이터 조회·변경·삭제 등의 공격 행위를 수행할 수 있다. 공격자가 이 취약점을 악용하기 위해서는 코드 실행 권한이 있어야 한다. 기기 공통보안취약점공개항목(CVE) 번호는 'CVE-2021-36934'다.

지디넷코리아

<이미지를 클릭하시면 크게 보실 수 있습니다>



이번 취약점에 대한 보안 패치는 아직 배포되지 않았다. 마이크로소프트(MS)는 해당 문제에 대한 일시적인 해결책으로, SAM이 위치한 폴더 접근을 제한하고, 공격자가 우회 접근을 시도할 수 있는 볼륨 섀도 복사본(VSS)도 삭제할 것을 당부했다. 미국 IT 매체 블리핑컴퓨터는 이번 주 후반 보안 업데이트가 출시될 가능성이 높다고 전망했다.

MS는 이번 취약점의 악용 사례는 발견되지 않았다고 했으나, 악용 가능성을 '높음'으로 평가했다. 이는 공격자가 해당 취약점을 익스플로잇으로 악용할 가능성이 크고, 이 취약점이 유효한 환경에 있는 사용자는 높은 우선 순위를 두고 보안 조치를 실시해야 한다는 것을 의미한다.

리눅스 취약점의 경우 지난 20일 글로벌 보안 회사 퀄리스 연구팀이 '세쿼이아(Sequoia)'라는 명칭으로 보고한 로컬 권한 상승 취약점이다. CVE 번호는 'CVE-2021-33909'가 부여됐다.

지디넷코리아


연구팀은 취약점 검증 결과 리눅스 OS인 우분투 20.04·20.10·21.04와 데비안 11, 페도라 34 워크스테이션에서 이 취약점을 악용해 시스템 권한을 획득할 수 있었다며, 2014년 이후 출시된 다른 리눅스 배포판에서도 취약점이 유효할 것이라고 밝혔다. 공격에는 약 3분이 소요됐다.

퀼리스 연구팀은 해당 취약점에 대한 보안 패치를 즉각적으로 적용하라고 권고했다.

김윤희 기자(kyh@zdnet.co.kr)

<© 메가뉴스 & ZDNET, A RED VENTURES COMPANY, 무단전재-재배포 금지>
기사가 속한 카테고리는 언론사가 분류합니다.
언론사는 한 기사를 두 개 이상의 카테고리로 분류할 수 있습니다.